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1 Requirements

This guide is for programming a system using the Rasoft Pro software which is available for
download at http://www.rakocontrols.com/support/software.

Programming the system will require a WK-HUB and a Windows or Mac computer. It may
also be useful to have a full list of the Rooms and circuits that will be included in the project
so these can be entered when using the new project wizard.

2 Create a new Rasoft Pro Project File
All projects in Rasoft Pro require a file to be created, to create a new project file:

- Open Rasoft Pro

- Select “File” > “New Project” to bring up the new project wizard.

2.1 Project name and House numbers

- Choose a suitable project name, typically the name of the property.

- Choose a House Number, typically the House Number of the property, and select
"Next".
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IMPORTANT
Every Rako system must be assigned a House number. Rasoft Pro will suggest a House
number based on previous projects by default; a custom House number can be selected if
preferable. Do not use House 1.

2.2 Save Locations

Select the Save Location for the project file. It is best to use the default save location
(C:/Users/[user]/Rako) for Windows or (Macintosh HD/Users/[user]/Rako) for MacOS.

Files saved at this location will appear in recent projects on the Rasoft Pro home screen
when re-opened.

2.3 Adding Rooms

The next step of the Setup Wizard requires adding the Rooms, additional Rooms can be
added later if required, this step can also be skipped entirely if the Room names are not yet
known.

- Using the text field, give the Room a name.

- Select the "Room Type".

- Select "Add".

- Repeat the previous steps for each Room required.
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Once a Room has been added, it will appear under the Room List heading with an
automatically assigned Room number. Continue adding until the box on the right-hand side
is populated with all the Rooms in the property. Rooms can be deleted anytime by
highlighting them and clicking “Delete Selected.”

NB
If Wireless modules are addressed to a Room with a changed number, they will all have to
be re-addressed as if they were new.

2.4 Adding Channels

In the “Add Channels” screen, all the added Rooms will appear along the top. Each column
below the Room name lists the Channels within that Room.

- Enter the name of each circuit for the corresponding Rooms, each column has 15
cells which represent Channel 1 through to Channel 15.
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NB

A Rako Room can have a maximum of 15 Channels.

2.5 Connecting to a WK-HUB

Before Devices can be added to the Project File, the WK-HUB needs to be set up as a
communication Device, this allows the Wired system to be programmed between Rasoft
Pro and the Windows or Mac computer. Once the project file is set up and Devices are
added, the WK-HUB is uploaded with the Room, Channel, and Scene data to enable the
use of the Rako App.

Before continuing, read the WK-HUB Instruction Manual up to section 4, as the Device
must first be configured before programming the system.

- In the Communication Devices window at the bottom
right side of Rasoft Pro, select "Refresh", the
WK-HUB should appear with a red stop sign.

- Right-click the WK-HUB and select
"Connect/Disconnect"

- The stop sign will change to a green tick, the Wired
system is ready to be configured.
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3 Addressing the RAK-LINK

The RAK-LINK is an essential component of a Wired system, it serves as a power supply for
Rako Wired Devices and communicates between the Rako Wired system and connected
RAKs.

3.1 Adding the RAK-LINK as a Device

- Press and hold the setup button on the top circuit board and a solid blue light will
illuminate on LED 1, once the blue light is flashing release the button.

- A pop-up box will appear in Rasoft Pro, give the RAK-LINK a name and select
"Next", and then select "Next" again.

- Select "Finish"
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3.2 Device Status

Devices that are connected to the CAN network will have a Device status at the top right of
the Device editor, when a Device is selected, the status will appear in the Device Status
section.

Online: Indicates that the WK-HUB is communicating with the Device, along with its version
number.

Virtual Device: This Device has not been addressed, although the programming menus are
still accessible, this occurs if setup has not been completed successfully or if a Device has
been added off-site to be added to the project file later.

Not Found: The Device is assigned in Rasoft, but it was not discovered.

No Comms to check: Rasoft cannot talk to the CAN network at all. Usually means that the
HUB is not connected to the computer correctly or there is an error connecting to the IP
network.
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3.3 RAK-LINK Diagnostic LEDs

The RAK-LINK has three LEDs which can provide useful information about the Wired system:

LED No. Colour Indicator Uses/example

1 Blue Device activity ● Device in setup
● Network looping poll

2 Blue Power/CAN bus
activity

● Solid Power detected
● Flashing CAN Bus Rx/Tx

3 Red CAN Diagnostics ● CAN warning
● CAN error

4 Adding circuits to the RAK-LINK

Once the RAK-LINK has been added as a Device, the connected RAKs and their outputs
need to be configured.

4.1 Adding RAKs to the RAK-LINK

- Select the RAK-LINK in the Devices section

- Set the box numbers on the RAK8, there can be no more than four RAK8s on a single
RAK-LINK.

Box No. Dip switches Description

Box 0 All dip switches down

Box 1 Dip switch 1 up
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Box 2 Dip switch 2 up

Box 3 Dip switch 1+2 up

- On the RAK-LINK Device editor, select "Auto Discover". The RAK8s will populate in
the window above sorted by their assigned box number.

NB

Auto Discover is intended for RAK8s only, if the older RAKs are used then they
need to be added manually, to do this, select "Specify extra RAK" at the bottom of the
RAK-LINK configuration page.

The RAK type will need to be set for each RAK4 to display the correct programming menus.

4.2 Identifying RAK output circuits

Before the mapping of the RAKs can be done, each output needs to be identified, if the
circuit outputs are unknown, the RAK8’s test buttons can be used.

Each press of the test button will toggle the respective circuit on/off.

Ensure that the connected loads are made safe before testing.
Do not touch any part of the circuit board other than the test buttons when energised.
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4.4 Mapping the RAK-LINK

Once the circuits have been identified and the RAKs have been added to the RAK-LINK, the
circuits can be mapped to their respective Rooms and Channels.

- On the RAK-LINK Device Editor, select "Mappings"

- Select the Room and Channel for each row, which corresponds to the Box and
Circuit output number of the RAK.

Once the mappings section has been completed, select "Save & Upload" for the changes
to take effect.

To confirm that the circuits have been mapped successfully, select a Room from the Room
List and the Channels will have an output assigned to them, as below.

NB
If a Room is selected but the channel box is left blank then this circuit
Will remain unmapped. This means it will not respond to commands even from the
assigned Room number.
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4.3 RAK8-MB extra features

Additional information can be found on the RAK8-MB by
selecting "RAK8 Info" on the RAK-LINK Device Editor.

When selected, the RAK8-MB will be scanned and the
feedback will appear with the following information

- Card types and version
- Cards current level
- RAK8-MB version

If a card is not found, or there is no card inserted into the RAK8-MB slot "Not Found" will
be shown.

RAK8 Info window in Rasoft Pro, the interface will vary depending on the RAK.

Commands can be sent from the interface above by selecting "Other" and then the Scene
required, this can be useful when identifying circuit outputs.
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5 Wired Switch Setup

5.1 WCM

The WCM is a wall controller for use within a Rako Wired
system, it is designed to fit in a standard UK back box for wall
mounting.

Depending on the WCM requirement, many button
configurations are possible, ranging from Lighting, Blind and
Audio control.

Through Rasoft Pro, commands can be assigned to the
buttons to perform actions, such as switching a Scene for a
Room or closing Blinds.

5.1.1 Addressing the WCM

To add a WCM to the Wired network, first ensure that the previous steps in the guide have
been followed.

- In Rasoft Pro go to File > New Device

- Select WCM (Wired Plate) in the Device List, select "Next"
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- Give the WCM a name and select "Next"

- Associate the WCM to a Room and select "Next"

- Press and hold the buttons G and I until the LED’s begin to pulse

- The blue status bar should each 100% and "Device found" will show in the setup,
select "Next"
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- Select a suitable template, and check the layout number on the box to find the
correct template, for example, if the box label is WCM-070, use the WCM-070
template.

Once the WCM has been added to Rasoft Pro, it will appear in the Device List and it
is ready to be configured:

5.1.2 Configuring the WCM

Once the WCM has been added to Rasoft Pro, it can be configured further if additional
programming is required which are not part of the default template.

- Select the WCM in the Device List which requires configuring
-
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Mappings (1)

A mapping is an input on a button identified by a letter, the WCM has 10 inputs labelled A -
J, it is possible to have multiple mappings for the same letter although it is not
recommended. When more than one command is being sent from a single button, it is
recommended to use the WK-HUB macros.

New mappings can be created by selecting a "disabled" mapping and then selecting the
input options and output action, there can be up to 32 mappings on a WCM.

NB
Existing mappings can be duplicated by right-clicking the mapping and selecting "Copy",
then right-clicking a "disabled" mapping and selecting "Paste", this is common when
programming another input with a similar output action and can speed up programming
time.

Keypad layout (2)

The Keypad layout is used to configure the mapped input logic and when to trigger an
output action.

Function Description

LEDs When the LEDs option is set to "On" it will
illuminate the LED on the button when it is
pressed, in contrast, the other buttons which are
not pressed will turn off which can be seen in
the example.

Enabled
The enabled checkbox must be ticked in order
for the button to function.

Send Stop On Release When the button is released, a "Stop"
command will be triggered.

Trigger on press Trigger the output command when the button is
pressed.
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Trigger on release Trigger the output command when the button is
released.

Output Action (3)

The output actions of the buttons inputs are set up in the button action section, the
following options are available:

Function Description

Room The Room number of the output command.

Channel The Channel number of the output
command, can be All Channels or a single
Channel.

Disable map When enabled, the button input will have
no output command.

Scene If a Scene is being triggered, select a Scene
between 1-16.

Fade-Up/Fade-Down Commonly used to manually dim lighting
up and down, as well as the
opening/closing of blinds.

NB
"Send Stop on Release" should also be
checked when using this option.

Motor Stop Used to stop 3rd party motors that are
configured within the HUB.

Ident This option is not recommended, as the
command will make a load flash
momentarily and provides no practical
function for daily use.

Toggle The Toggle function will alternate between
two commands, either a Level command
and Off, or a Scene command and Off.

Level Sets the lighting Level to a percentage of
brightness between 0-100%.

Tunable White Set the colour temperature output.
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Macro Trigger an internal Macro on the Device;
this is not the same as triggering a Macro
on a WK-HUB.

5.2 WK-EOS

The WK-EOS is a 6-button Wired Keypad used in a Rako
Wired Network.

Through Rasoft Pro, commands can be assigned to the
buttons to perform actions, such as switching a Scene for a
Room or closing Blinds.

5.2.1 Addressing the WK-EOS

To add a WK-EOS to the Wired network, ensure that the previous steps in the guide have
been followed to create a project file and connect to the WK-HUB.

- In Rasoft Pro go to File > New Device

- Select WK-EOS in the Device List, select "Next"

K

- Give the WK-EOS a name and select "Next"
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- Associate the WK-EOS to a Room and select "Next"

- Press and hold the raise and lower buttons until the LEDs begin to pulse

- The blue status bar should each 100% and "Device found" will show in the setup,
select "Next"

- Select a template and select "Finish"
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5.2.2 Configuring the WK-EOS

Once the WK-EOS has been added to Rasoft Pro, it can be configured further if additional
programming is required which are not part of the default template.

- Select the WK-EOS in the Device Editor

Mappings (1)

A mapping is an input on a button identified by a letter, the WK-EOS has 6 inputs labelled
A - F, it is possible to have multiple mappings for the same letter although it is not
recommended. When more than one command is being sent from a single button, it is
recommended to use the WK-HUB macros.

New mappings can be created by selecting a "disabled" mapping and then selecting the
input options and output action, there can be up to 32 mappings on a WK-EOS.

NB
Existing mappings can be duplicated by right-clicking the mapping and selecting "Copy",
then right-clicking a "disabled" mapping and selecting "Paste", this is common when
programming another input with a similar output action and can speed up programming
time.
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Keypad layout (2)

The Keypad layout is used to configure the mapped input logic and when to trigger an
output action.

Function Description

LEDs When the LEDs option is set to "On" it will
illuminate the LED on the button when it is
pressed, in contrast, the other buttons which are
not pressed will turn off which can be seen in
the example.

Enabled
The enabled checkbox must be ticked in order
for the button to function.

Send Stop On Release When the button is released, a "Stop"
command will be triggered.

Trigger on press Trigger the output command when the button is
pressed.

Trigger on release Trigger the output command when the button is
released.
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Output Action (3)
The output actions of the buttons inputs are set up in the button action section, the
following options are available:

Function Description

Room The Room number of the output command.

Channel The Channel number of the output
command, can be All Channels or a single
Channel.

Disable map When enabled, the button input will have
no output command.

Scene If a Scene is being triggered, select a Scene
between 1-16.

Fade-Up/Fade-Down Commonly used to manually dim lighting
up and down, as well as the
opening/closing of blinds.

NB
"Send Stop on Release" should also be
checked when using this option.

Motor Stop Used to stop 3rd party motors that are
configured within the HUB.

Ident This option is not recommended, as the
command will make a load flash
momentarily and provides no practical
function for daily use.

Toggle The Toggle function will alternate between
two commands, either a Level command
and Off, or a Scene command and Off.

Level Sets the lighting Level to a percentage of
brightness between 0-100%.

Tunable White Set the colour temperature output.

Macro Trigger an internal Macro on the Device;
this is not the same as triggering a Macro
on a WK-HUB.
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5.3 WK-MOD

The WK-MOD is a modular Keypad used in a Rako Wired
network, it is available in a wide variety of button
configurations, as well as fully customisable button
positioning and sizes should it be required.

Through Rasoft Pro, commands can be assigned to the
buttons to perform actions, such as switching a Scene for a
Room or closing Blinds.

5.3.1 Addressing the WK-MOD

To add a WK-MOD to the Wired network, ensure that the previous steps in the guide have
been followed.

- In Rasoft Pro go to File > New Device

- Select WK-MOD (Wired Plate) in the Device List, select "Next"
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- Give the WK-MOD a name and select "Next"

- Associate the WK-MOD to a Room and select "Next"

- Press and hold any button, and press any other button three times.

- The blue status bar should each 100% and "Device found" will show in the setup,
select "Next"

- Select a template, the button configuration will be printed on the box, if it is a
custom button layout, this can be configured within the WK-MOD menu after the
setup wizard has completed.
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- Once a suitable template has been selected, select “Next”

- The WK-MOD will appear in the Device list once successfully set up.

5.3.2 Configuring the WK-MOD

Once the WK-MOD has been assigned in Rasoft Pro, it can be configured further in the
Device editor.

- Select the WK-MOD in the Device editor
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Mappings (1)

All programmed inputs for the Device must first have a mapping. The purpose of a
mapping is to program a button to perform a specific command. Each input has its own
letter to represent its input, there are up to 12 inputs on the WK-MOD.

New mappings can be created by selecting a disabled field and selecting the
corresponding input letter in the next column:

Active mappings can be copied or pasted into disabled mappings; this is typically used
when re-using similar functions of an existing mapping to save time, such as a toggle
function.

Mapping right-click options

NB
Ensure only a single letter is used for each mapping, otherwise, the mapping will not
function unless all inputs are pressed at the same time.

Keypad layout (2)

The Keypad layout is used to configure the mapped input logic and when to trigger an
output action.
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Function Description

LEDs When the LEDs option is set to "On" it will
illuminate the LED on the button when it is
pressed, in contrast, the other buttons LEDs will
be ignored, which can be seen in the example
above.

Enabled
The enabled checkbox must be ticked in order
for the button to function.

Send Stop On Release When the button is released, a "Stop"
command will be triggered.

Trigger on press Trigger the output command when the button is
pressed.

Trigger on release Trigger the output command when the button is
released.

Output Action (3)

The output actions of the buttons inputs are set up in the button action section, the
following options are available:
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Function Description

Room The Room number of the output command.

Channel The Channel number of the output
command can be All Channels or a single
Channel.

Disable map When enabled, the button input will have
no output command.

Scene If a Scene is being triggered, select a Scene
between 1-16.

Fade-Up/Fade-Down Commonly used to manually dim lighting
up and down, as well as the
opening/closing of blinds.

NB
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"Send Stop on Release" should also be
checked when using this option.

Motor Stop Used to stop 3rd party motors that are
configured within the HUB.

Ident This option is not recommended, as the
command will make a load flash
momentarily and provides no practical
function for daily use.

Toggle The Toggle function will alternate between
two commands, either a Level command
and Off, or a Scene command and Off.

NB
Do not map more than one Toggle to a
single button on the inputs; this will result
in sporadic switching due to toggles
getting out of sync.

Level Sets the lighting Level to a percentage of
brightness between 0-100%.

Tunable White Set the colour temperature output.

Macro Trigger an internal Macro on the Device;
this is not the same as triggering a Macro
on a HUB.

NB
Macros can be created on the "Macro" tab
above the button configuration.



Keypad Layout Editor

The WK-MOD has fully customisable button layouts, which can be configured in the
WK-MOD Device menu.

The Keypad Layout Editor is found by selecting the tab above the mappings window:

- Existing templates can be loaded into the mapping page which will change the
button layout.

- Highlight the desired layout name and choose "Select Layout"

- The layout will now be loaded on the "Button Config (Mapping)" page.
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5.4 WCM-D

The WCM-D allows custom and third-party switch plates to be
used in place of a Rako Wired Keypad
(WCM/WK-EOS/WK-MOD etc.)

The WCM-D will fit inside a single gang UK back box. Up to
eight switch inputs can be taken per WCM-D. The switch plate
can be formed of latching or momentary action switches
connected by short wires to terminals on the WCM-D.

5.4.1 Addressing the WCM-D

To add a WCM to the Wired network, ensure that the previous
steps in the guide have been followed to create a project file and connect to the WK-HUB.

- In Rasoft Pro go to File > New Device

- Select "WCM-D" and "Next"

- Give the WCM-D a name and select "Next"
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- Associate the WCM-D to a Room and select "Next"

- Connect the Common and Setup terminals together until the LED on the WCM-D
flashes, then remove the link.

NB
Older models of the WCM-D have a different method of setup, see the WCM-D
Instruction Manual for more information

- The blue status bar should each 100% and "Device found" will show in the setup,
select "Next"
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5.4.2 Configuring the WCM-D

Once the WCM-D has been added as a Device, it needs to be configured according to the
3rd party switch inputs.

- Select the WCM-D in the Device Editor

Mappings (1)

All programmed inputs for the Device must first have a mapping. The purpose of a
mapping is to program a button to perform a specific command. Each input has its own
letter to represent its input, there are up to 8 inputs on the WCM-D.

New mappings can be created by selecting a disabled field and selecting the
corresponding input letter in the next column:

Active mappings can be copied or pasted into disabled mappings; this is typically used
when re-using similar functions of an existing mapping to save time, such as a toggle
function.

Mapping right-click options
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NB
Ensure only a single letter is used for each mapping, otherwise, the mapping will not
function unless all inputs are pressed at the same time.

Inputs (2)

The inputs for the mappings are configured in the Inputs section.

When an input is highlighted blue, it will set the corresponding input letter active in the
mapping, selecting the input multiple times will cycle through the input options which are
“Normal”, “Ignore” and “Invert”, an example can be seen below:

"A - Normal" creates a mapping for input A, ensuring that only one input is highlighted
blue for each mapping.

If A is set as "Invert", the "On Make" and "On Break" commands will reverse.
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Option Description

Trigger on Make When the switch input makes contact,
trigger the output command.

Trigger on Break When a switch breaks its contact, trigger
the output command.

Send Stop On Release When the made contact is released, a
"Stop" command will be triggered

Trigger on Press Trigger the output command when the
momentary switching makes contact
between its input and common.

Trigger on Release Trigger the output command when the
momentary switch breaks contact between
its input and common

Don't update previous Room If this box is ticked this map will not update
the “last used” flag for both Room and
Channel. When a “last used” is sent from
this Device the most recent Room and
Channel sent which doesn't have “don't
update previous Room” selected will be
sent.

Output Action (3)

Option Description

Room The Room number of the output command.

Channel The Channel number of the output
command can be All Channels or a single
Channel.

Disable map When enabled, the button input will have
no output command.

Scene If a Scene is being triggered, select a Scene
between 1-16.
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Fade-Up/Fade-Down Commonly used to manually dim lighting
up and down, as well as the
Opening/Closing of Blinds.

NB
"Send Stop on Release" should also be
checked when using this option.

Motor Stop Used to stop 3rd party motors that are
configured within the HUB.

Ident This option is not recommended, as the
command will make a load flash
momentarily and provides no practical
function for daily use.

Toggle The Toggle function will alternate between
two commands, either a Level command
and Off, or a Scene command and Off.

Level Sets the lighting Level to a percentage of
brightness between 0-100%.

6 Setting scenes

A Scene can be any percentage between 0-100%, once a Scene is saved, it can be recalled
using a "Scene" command.

In Rasoft Pro, click on the Room to bring up the Room editor tab and select the Room which
requires a scene change.

Select a Scene (the selected Scene button will outline blue)

Wired system setup guide Version 2.0.1



Move the slider for each Channel to the desired light Level

Press “Store Scene”

Scenes can be renamed by editing the text fields.

To add additional Scenes to set, select "Add Scene"
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6.2 Advanced Scene Setting Features:

To access additional Scene setting features, right-click on the “Store Scene” button to make
a drop-down menu appear:

Extra options allow Rooms to be transmitted without the need to individually reset every
slider for every Channel.

Send Store Command:

Performs the same function as pressing the “Store Scene” button normally (left clicking).

Transmit all sliders:

Re-transmits all the current slider Levels for the selected Room.

Write Scene “1” Level Data:

Uploads all Levels and stores the currently selected Room (in this case Room 1)

Write All Scenes Level Data:

Re-uploads all Room information for the Room to all dimmers addressed to it.
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Appendix 1 Setting up a WK-HUB
A1.2.1 Connections

- Connect the HUB to an accessible network via the supplied Ethernet cable.

- Connect the power supply.

- Allow 2-3 minutes for the HUB to start up; there will be a blue light on the top when
the HUB has finished starting up.

- Select "Refresh" on the communications Devices

- Right-click the HUB in communication Devices and select "Connect/Disconnect"

- A green tick will verify that the connection has been successful.

NB
The House number for the project file and the House number on the HUB must be
the same, if there is a mismatch, there will be a warning in Rasoft Pro when
connecting to the HUB.

A1.2.2 Configuration
- Right-click the HUB in the communication Devices

- Select "Open in Browser"

- A web browser will open the HUB web pages.

- If this is the first time opening the HUB, the Setup Wizard will begin, Select "Next"
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- Choose a password and select "Next".

- Choose a name for the HUB, as well as the House address matching the Project in
Rasoft Pro. Select "Next".

- Select "Finish"
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The HUB basic setup is complete, if there are any Wireless Devices they can now be
configured.

As a final check, it is advisable to disconnect and reconnect to the HUB:

If no pop-up box appears, then the HUB House number and Project file House number are
the same.

WARNING
If a pop-up box appears with a warning about the House number, click "Cancel.” Do not
continue programming this means there is a conflict between the Project File House
number and the House number on the HUB.

A1.2.3 Adding the HUB as a Device in Rasoft Pro
Once the HUB has been configured in the web pages, it needs to be added as a Device to
Rasoft Pro to upload the Room and Room information for App control.

- Connect to the HUB by double-clicking it in the communication Devices; a green
tick will show to verify the connection has been successful.

- Go to "File > New Device"
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- Select "HUB/Bridge" and "Next"

- The IP address of the HUB will appear in the next window; highlight it and select
"Finish"

- The HUB has now been added as a Device in Rasoft Pro.

Once the HUB has been added as a Device, it will require further setup for App control, see
A5 Uploading to a HUB/Bridge and App setup for further information.
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Appendix 2 Power-Up Mode
The Power-Up mode determines the Level or Scene a Device will output when it is initially
switched on at the supply.

NB
The default Power-Up mode is 100%

A2.1 Setting A Global Power-Up Mode

It is possible to set the Power-Up Modes “globally” for the entire System. To access this
menu:

- Select “Tools” > “Global Power Up”.

- Select the Power-Up Mode required.

- For systems which are left empty for long periods of time, "Off" is a recommended
Power-Up Mode.

- Systems that are constantly in use, "Last Scene" is a recommended Power-Up Mode.
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Appendix 3 Fade rates
Using Rasoft Pro, it is possible to edit the rate at which Rako modules Fade between
Lighting Levels.

A3.1 Change the Fade Rate for a Room

- Open the Room editor, right-click Room Devices and select "Fade Rates".

NB
This will set Fade Rates for every Device in the Room. To set Fade Rates for a specific
Device, select it in the Device List and click on the Fade Rates tab in the Device editor.

The Fade Rate menu will be displayed as below.
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Two types of Fade Rates can be adjusted:

Scene controls

The rate at which Circuits move between Rooms (including Off).

Fader controls

Will change the rate at which Circuits dim up or down when the Fade buttons (raise/lower)
are used.

NB
Setting all of the fader controls to max speed will make it almost impossible to dim the
lights from the Fade Up/Fade Down buttons.

A3.2 Change the Fade Rate for a Channel
When a specific Room requires a change in Fade Rate, it can be adjusted in the Room
Editor.

- Go to the Room Editor, and right click the assigned Device, select "Go to (Device)"

- Select the "Fade Rate" tab
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Appendix 4 Uploading to a HUB and App setup
After a system has had all Rooms, Channels and Devices added, the information needs to
be uploaded to the HUB in order to control the System via the App and the web pages.

- Select the HUB in the Device List

- Select "Smartphone/Web Data"

- Select "Save & Upload Room Data to HUB/Bridge"

The Room, Channel and Scene information is now uploaded to the HUB, and can
be accessed via the Rako App or via the HUB webpages.

A4.1 Room Mode

The App will display a 4 Scenes + Off arrangement by default, there are additional
options depending on the control panels used and the number of Scenes required
in the App.

To change the Room Mode:

- In the Smartphone/Web Data section, select the "Mode" drop down menu
for the relevant Room.
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- Select the required option for each Room.

- Select "Save & Upload Room Data to HUB/Bridge"

A4.2 Room Type

If a Room is not for dimmable lighting, the Type can be changed.

- In the "Smartphone / Web Data" menu, select the "Type" drop-down menu
for each Room to specify its Type.

- Once the Room Types have been set, select "Save & Upload Room Data to
HUB.
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A4.3 Channel Type

Similar to Room Type, individual Channels can be set to different circuit types, the
most common use is setting a non-dimmable circuit to "Switch" which will remove
dimming options on the App and instead give an "On/Off" option.

To set a Channel Type:

- In the Smartphone/Web Data section, select the Room to highlight it and
select the "Type" drop-down menu for the relevant Channel.

- Once the Type has been selected for all of the relevant Channels, select
"Save & Upload Room Data to HUB/Bridge"

A4.4 Smartphone / Web Data Options

Enable

When the box is ticked, the Room will appear in the App, Rooms which are not intended
for direct control via the App should be unticked.
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Title

The names of the Rooms on the left side menu will be displayed here, and the names in the
list will appear in the App.

Type

Changes the options available for the Channel in the App, for example, if a circuit is
changed to a "Switch", in the App an "On/Off" layout will be shown rather than a Slider.

Mode

Depending on the requirements of the Room on the App, the Mode can be set to show
different button configurations, the correct configuration will depend on the individual
requirements as well as the Keypads used.

Room Order

The order of the rooms can be adjusted by selecting the header to sort numerically or
alphabetically, and by dragging the rooms up/down to create a customisable order.
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