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1 Requirements 
 
This guide is for programming a system using the Rasoft Pro software, which is available for 
download at http://www.rakocontrols.com/support/software. 
 

 
       
 

 
Programming the system will require a WK-HUB and a Windows or Mac computer. It may 
also be useful to have a full list of the Rooms and Channels that will be included in the 
project, so these can be entered when using the new project wizard. 

2 Create a new Rasoft Pro Project File 
All projects in Rasoft Pro require a file to be created. To create a new project file: 
 
➔​ Open Rasoft Pro 

 
➔​ Select “File” > “New Project” to bring up the new project wizard.  

2.1 Project name and House numbers 
 
➔​ Choose a suitable project name, typically the name of the property. 

 
➔​ Choose a House Number, typically the House Number of the property, and select 

"Next". 
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2.2 Save Locations 
 
➔​ Select the Save Location for the project file.  

 
➔​ Files saved at this location will appear in recent projects on the Rasoft Pro home 

screen when reopened. 
 

 

2.3 Adding Rooms 
 
The next step of the Setup Wizard requires adding the Rooms. Additional Rooms can be 
added later if required. This step can also be skipped entirely if the Room names are not yet 
known.   
 
➔​ Using the text field, give the Room a name.  

 
➔​ Select the "Room Type". 

 
➔​ Select "Add".  

 
➔​ Repeat the previous steps for each Room required.  
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Once a Room has been added, it will appear under the Room List heading with an 
automatically assigned Room number. Continue adding until the box on the right-hand side 
is populated with all the Rooms in the property. Rooms can be deleted anytime by 
highlighting them and clicking “Delete Selected.” 

2.4 Adding Channels 
 
In the “Add Channels” screen, all the added Rooms will appear along the top. Each column 
below the Room name lists the Channels within that Room. 
 
➔​ Enter the name of each Channel for the corresponding Room. Each column has 15 

cells, which represent Channel 1 through to Channel 15. 
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2.5 Connecting to a WK-HUB 
 
Before Devices can be added to the Project File, the WK-HUB needs to be set up as a 
communication Device. This allows the Wired system to be programmed between Rasoft 
Pro and the Windows or Mac computer. Once the project file is set up and Devices are 
added, the WK-HUB is uploaded with the Room, Channel, and Scene data to enable the 
use of the Rako App.   
 
Before continuing, read the WK-HUB Instruction Manual up to section 4, as the Device 
must first be configured before programming the system. 
 
➔​ In the Communication Devices window at the bottom 

right side of Rasoft Pro, select "Refresh". The 
WK-HUB should appear with a red stop sign. 

 
➔​ Right-click the WK-HUB and select 

"Connect/Disconnect" 
 

➔​ The stop sign will change to a green tick. The Wired 
system is ready to be configured.  
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SELECT A SYSTEM TYPE BEFORE CONTINUING  
 

There are two wired system types to choose from, which vary in their setup instructions. Go 
to the relevant section to continue the setup. 

 
 

 

                RAK System​ ​ ​ ​ ​    DIN System 

    ​ ​        ​ 
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3 Addressing the RAK-LINK 
The RAK-LINK is an essential component of a Wired RAK system. It serves as a power 
supply for Rako Wired Devices and communicates between the Rako Wired Network (also 
referred to as RWN) and connected RAKs. 

3.1 Adding the RAK-LINK as a Device  
 
➔​ Press and hold the setup button on the top circuit board, and a solid blue light will 

illuminate on LED 1. Once the blue light is flashing, release the button.  
 

           
 
 
➔​ A pop-up box will appear in Rasoft Pro, give the RAK-LINK a name and select 

"Next", and then select "Next" again.  
 

 
 
➔​ Select "Finish" 
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3.2 Device Status 
 
Devices that are connected to the RWN will have a Device status at the top right of the 
Device editor. When a Device is selected, the status will appear in the Device Status 
section.  
 

 
Online: Indicates that the WK-HUB is communicating with the Device. The version number 
of the Device is shown.  
 

 
Virtual Device: This Device has not been addressed. Programming menus are still 
accessible. This occurs if the setup has not been completed successfully or if a Device has 
been added off-site to be added to the project file later.  
 

 
Not Found: The Device is assigned in Rasoft, but cannot communicate with the HUB.  
 

 
No Comms to check:  The HUB is not connected to the computer correctly or there is an 
error connecting to the IP network.  
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3.3 RAK-LINK Diagnostic LEDs 
 
The RAK-LINK has three LEDs for feedback and diagnostics of the RAK-LINK and Wired system: 
 

LED No. Colour Indicator Uses/example 

1 Blue Device activity ●​ Device in setup (slow flash) 
●​ Network looping poll (fast flash) 

2 Blue Power/CAN bus 
activity 

●​ Solid: Power detected 
●​ Flashing: CAN Bus Rx/Tx 

3 Red CAN Diagnostics ●​ CAN: warning  
●​ CAN: error 

4 Adding circuits to the RAK-LINK 
Once the RAK-LINK has been added as a Device, the connected RAKs and their outputs 
need to be configured. 

4.1 Adding RAKs to the RAK-LINK 
 
➔​ Select the RAK-LINK in the Devices section  

 

 
 

➔​ Set the box numbers on the RAK8; there can be no more than four RAK8s on a 
single RAK-LINK.  

 
 

Box No. Dip switches Description 

Box 0 

 

All dip switches down 

Box 1 

 

Dip switch 1 up 
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Box 2 

 

Dip switch 2 up  

Box 3 

 

Dip switch 1+2 up 

 
➔​ On the RAK-LINK Device editor, select "Auto Discover". The RAK8s will populate in 

the window above, sorted by their assigned box number. 
 

 
 

 
 
The RAK type will need to be set for each RAK4 to display the correct programming menus.  
 

4.2 Identifying RAK output circuits 
 
Before mapping the RAKs, each output needs to be identified. If the circuit outputs are 
unknown, the RAK8’s test buttons can be used.  
 
Each press of the test button will toggle the respective circuit on/off. 
 

 
Ensure that the connected loads are made safe before testing. 
Do not touch any part of the circuit board other than the test buttons when energised. 
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4.4 Mapping the RAK-LINK  
 
Once the circuits have been identified and the RAKs have been added to the RAK-LINK, the 
circuits can be mapped to their respective Rooms and Channels. 
 
➔​ On the RAK-LINK Device Editor, select "Mappings"  

 
➔​ Select the Room and Channel for each row, which corresponds to the Box and 

Circuit output number of the RAK. 
 

 
 
Once the mappings section has been completed, select "Save & Upload" for the changes 
to take effect.  
 
To confirm that the circuits have been mapped successfully, select a Room from the Room 
List. The Channels will have an output assigned to them, as below.  
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4.3 RAK8-MB extra features  
 
Additional information can be found on the RAK8-MB by 
selecting "RAK8 Info" on the RAK-LINK Device Editor. 
 
When selected, the RAK8-MB will be scanned and the 
feedback will appear with the following information 
 

●​ Card types and version 
●​ Card current level 
●​ RAK8-MB version  

 
If a card is not found, or there is no card inserted into the RAK8-MB slot, "Not Found" will 
be shown.  
 

 
RAK8 Info window in Rasoft Pro, the interface will vary depending on the RAK.  

 
Commands can be sent from the interface above by selecting "Other" and then the Scene 
required. This can be useful when identifying circuit outputs.  
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5 Addressing the DIN-LINK 
 
The DIN-LINK is an essential component of a Wired DIN system. It serves as a power supply 
for Rako Wired Network devices via the DIN-PSU-100 and communicates between the RWN 
and the DIN bus modules.  

5.1 Adding the DIN-LINK as a Device  
 
➔​ Press and hold the setup button on the top circuit board, and a solid white light will 

illuminate on LED 1. Once the white light is flashing, release the button.  
 

       
 
➔​ A pop-up box will appear in Rasoft Pro, give the DIN-LINK a name and select 

"Next", and then select "Next" again.  
 

 ​  
 
 
➔​ Select "Finish" 
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5.2 Device Status 
 
Devices that are connected to the RWN will have a Device status at the top right of the 
Device editor. When a Device is selected, the status will appear in the Device Status 
section.  
 

 
Online: Indicates that the WK-HUB is communicating with the Device, along with its version 
number.   
 

 
Virtual Device: This Device has not been addressed. Programming menus are still 
accessible. This occurs if the setup has not been completed successfully or if a Device has 
been added off-site to be added to the project file later.  
 

 
Not Found: The Device is assigned in Rasoft, but it was not discovered. 
 

 
No Comms to check:  Rasoft cannot talk to the RWN. This indicates that the HUB is not 
connected to the computer correctly, or there is an error connecting to the IP network.  
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5.3 DIN-LINK Diagnostic LEDs 
 
The DIN-LINK has six LEDs, which can provide useful information about the RWN and DIN 
bus: 
 

LED 
No. 

Indicator Pattern Uses/example 

1 Device 
activity 

SOLID: Bootloader or button 
held 

The device is in setup 
 
RWN device polling mode 

2 Power/RWN 
activity 

BLINK: RWN Data Transmitting 
or Receiving  

Power detected 
 
Transmitting or receiving data  

6 Adding Mains DIN Modules to the DIN-LINK 
 
The following setup instructions cover the following DIN modules: 
 

●​ DIN-8S 
●​ DIN-4T 
●​ DIN-4C 

 
➔​ Select the DIN-LINK in the Devices section  

 

 
 

➔​ Set the box numbers on the DIN modules; there can be up to eight per DIN-LINK 
 

Box No. Dip switches Description 

Box 0 

 

All dip switches down 
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Box 1 

 

Dip switch 1 up 

Box 2 

 

Dip switch 2 up  

Box 3 

 

Dip switch 1+2 up 

Box 4 

 

Dip switch 3 up 

Box 5 

 

Dip switch 1+3 up 

Box 6 

 

Dip switch 2+3 up 

Box 7 

 

Dip switch 1+2+3 up 

 
➔​ On the DIN-LINK Device editor, select "Auto Discover". The DIN modules will 

populate in the window above, sorted by their assigned box number. 
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6.1 Identifying DIN output circuits 
 
Before the mapping of the DIN modules can be done, each output needs to be identified. 
If the circuit outputs are unknown, the DIN module test buttons can be used.  
 
Each press of the test button will toggle the respective circuit on/off.  
 

 
Ensure that the connected loads are made safe before testing. 
​
DIN-8S Test Buttons 

 
 
DIN-4T Test Buttons 
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DIN-4C Test Buttons 

 
 

6.2 Mapping the DIN-LINK  
 
Once the circuits have been identified and the DIN Modules have been added to the 
DIN-LINK, the circuits can be mapped to their respective Rooms and Channels. 
 
➔​ On the DIN-LINK Device Editor, select "Mappings"  

 
➔​ Select the drop-down menu for each Room and Channel, which corresponds to the 

Box and Circuit output number of the DIN module. 
 

 
 
Once the mappings section has been completed, select "Save & Upload" for the changes 
to take effect.  
 
To confirm that the circuits have been mapped successfully, select a Room from the Room 
List; the Channels will have an output assigned to them. 
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6.3 DIN-LINK Module Box Info Menu 
 

Additional information can be found on the DIN module by selecting "Box Info" on the 
DIN-LINK Device Editor. 

 
 
When selected, the DIN module will be scanned and the feedback will appear with the 
following information 
 

●​ Module Version 
●​ Current Scene 
●​ Current % Level 

 
If the DIN module is not found, "Not Found" will be shown.  

 
 

Wired system setup guide​ ​ ​               ​ ​                          Version 2.1.1 

 



 
 

7 Assigning a Wired Keypad 

7.1 WCM 
 
The WCM is a wall controller for use within a Rako Wired 
Network. It is designed to fit in a standard UK back box for 
wall mounting. 
 
Depending on the WCM requirement, many button 
configurations are possible, ranging from Lighting, Blind and 
Audio control.   
 
Commands can be assigned to the buttons to perform 
actions, such as switching a Scene for a Room or closing 
Blinds.  
 

7.1.1 Addressing the WCM 
 
➔​ In Rasoft Pro go to “File” > “New Device” 

 
 

➔​ Select WCM (Wired Plate) in the Device List, select "Next" 
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➔​ Give the WCM a name and select "Next" 
 

 
 

➔​ Associate the WCM with a Room and select "Next"  
 

 
 
➔​ Press and hold the buttons G and I until the LEDs begin to pulse  

            
 
➔​ The blue status bar should reach 100% and "Device found" will show in the setup, 

select "Next"  
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➔​ Select a suitable template; the device layout will be printed on the box, eg, 
WCM-070.  
 

Once the WCM has been added to Rasoft Pro, it will appear in the Device List and it is 
ready to be configured: 
 

 
 

 

7.2 WK-EOS 
 
The WK-EOS is a 6-button Wired Keypad used in a Rako 
Wired Network. 
 
Commands can be assigned to the buttons to perform 
actions, such as switching a Scene for a Room or closing 
Blinds.  

7.2.1 Addressing the WK-EOS 
 
To add a WK-EOS to the Wired network, ensure that the previous steps in the guide have 
been followed to create a project file and connect to the WK-HUB. 
 
➔​ In Rasoft Pro go to File > New Device 
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➔​ Select WK-EOS in the Device List, select "Next" 

 
 
➔​ Give the WK-EOS a name and select "Next" 

 
 
➔​ Associate the WK-EOS to a Room and select "Next"  
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➔​ Press and hold the raise and lower buttons until the LEDs begin to pulse  

            
 
➔​ The blue status bar should reach 100% and "Device found" will show in the setup, 

select "Next"  
 

 
 
➔​ Select a template and select "Finish" 
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7.3 WK-MOD 
 
The WK-MOD is a modular Keypad used in a Rako Wired 
Network. It is available in a wide variety of button 
configurations, as well as fully customisable button 
positioning and sizes should it be required.  
 
Through Rasoft Pro, commands can be assigned to the 
buttons to perform actions, such as switching a Scene for a 
Room or closing Blinds.  
 

7.3.1 Addressing the WK-MOD 
 
To add a WK-MOD to the Wired network, ensure that the previous steps in the guide have 
been followed.  
 
➔​ In Rasoft Pro go to File > New Device 

 
 
➔​ Select WK-MOD (Wired Plate) in the Device List, select "Next" 

 
 
➔​ Give the WK-MOD a name and select "Next" 
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➔​ Associate the WK-MOD to a Room and select "Next"  

 
 
➔​ Press and hold any button, and press any other button three times. 

 

 

            
 
➔​ The blue status bar should reach 100% and "Device found" will show in the setup. 

Select "Next".  
 

 
 
➔​ Select a template. The button configuration will be printed on the box. If it is a 

custom button layout, this can be configured within the WK-MOD menu after the 
setup wizard has completed.  
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​  
➔​ Once a suitable template has been selected, select “Next”  

 
 
➔​ The WK-MOD will appear in the Device list once successfully set up.  

 
 

 

8 Keypad Configuration 
 
The following instructions apply to the WCM, WK-EOS and WK-MOD. 
 
Once the Keypad has been added to Rasoft Pro, it can be configured further if additional 
programming is required which are not part of the default template. 
 
➔​ Select the Keypad in the Device List  

 
The device editor will appear and will be split into three sections, the appearance of the 
menu will vary slightly depending on the Keypad.  
 

Wired system setup guide​ ​ ​               ​ ​                          Version 2.1.1 

 



 
 

 

8.1.3 Mappings 
 
A Mapping is the input of a button, each assigned with a letter.  
 

Keypad Number of Inputs Range 

WCM 10  A to J 

WK-EOS 6  A to F 

WK-MOD 12  A to L 

 
Each button can have up to three mappings, allowing a single press to transmit multiple 
commands. For more than three mappings per button, use WK-HUB macros instead. 
 

 

8.1.4 Keypad layout  
 
The Keypad Layout is used to define when an Output Action is transmitted, as well as the 
state of the buttons' LED.  
 

Function Description 

LEDs Sets the LED state when the button is pressed.  

Enabled The enabled checkbox must be checked for the 
button to function.  
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Send Stop On Release When the button is released, a "Stop" 
command will be triggered. 

Trigger on press Trigger the output command when the button is 
pressed. 

Trigger on release Trigger the output command when the button is 
released. 

 

8.1.5 Output Action  
 
The commands transmitted by a button press are set in the "Output Action" section of the 
device editor. The available options include: 
 

Function Description 

Room The Room number of the output command. 

Channel The Channel number of the output 
command, can be All Channels or an 
individual Channel.  

No Action  

Scene A Scene is triggered, select a Scene 
between 1-16. 

Level  

Fade-Up/Fade-Down  Used to manually dim lighting circuits. Also 
for opening/closing blinds.  
 
"Send Stop on Release" must also be 
checked when using this option.  

Tunable White Set the colour temperature output. 

Macro Trigger a macro on the WK-HUB. 

Custom String Triggers custom strings set on the 
WK-HUB. 

Holiday Controls the Holiday Mode state between 
Playback and Record.  
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Motor Command Used to stop compatible 3rd party motors 
configured in the WK-HUB.  

Event Control Enable and disable Events on the WK-HUB 

Mapping Control Enable and disable mappings on the 
WK-HUB 

Macro Control Enable and disable Macros on the WK-HUB 

Toggle The Toggle function will alternate between 
two commands. There are three variations 
of Toggle:  
 

●​ Level (1-100%/0%) 
●​ Scene (Scene X/ Off) 
●​ Fade (Fade Up/Fade Down) 

Ident Causes the target Room/Channel to flash 
momentarily and is mainly used for circuit 
identification during commissioning. 

     

9 Setting Scenes 
 
➔​ In Rasoft Pro, click on the Room to bring up the Room editor tab and select the 

Room which requires a Scene change.  

 
 
➔​ Select a Scene (the selected Scene button will be outlined in blue) 

 
 
➔​ Move the slider for each Channel to the desired light Level 
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➔​ Press “Store Scene” 

 
 
➔​ Scenes can be renamed by editing the text fields. 

 
 
➔​ To add additional Scenes to set, select "Add Scene"  
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9.1 Advanced Scene Setting Features:  

To access additional scene setting features, right-click on the “Store Scene” button to make 
a drop-down menu appear: 
 

 
 
Extra options allow Rooms to be transmitted without the need to individually reset every 
slider for every Channel.   
 
Send Store Command: 
Performs the same function as pressing the “Store Scene” button normally (left clicking).  
 
Transmit all sliders:  
Re-transmits all the current slider Levels for the selected Scene.  
 
Write Scene “1” Level Data:  
Uploads all Levels and stores the currently selected Scene.  
 
Write All Scenes Level Data:  
Re-uploads all Scene information for the Room to all dimmers addressed to it.  
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Appendix 1 Setting up a WK-HUB 

A1.2.1 Connections 
 
➔​ Connect the HUB to an accessible network via the supplied Ethernet cable. 

 
➔​ Connect the RJ11 from the HUB to the Rako Wired Network. 

 
➔​ Allow 2-3 minutes for the HUB to start up; there will be a blue light on the top when 

the HUB has finished starting up.  
 

➔​ Select "Refresh" on the communications Devices 
 

➔​ Right-click the HUB in Communication Devices and select "Connect/Disconnect"  
 

➔​ A green tick will verify that the connection has been successful.  
 

 
NB 
The House number for the project file and the House number on the HUB must be 
the same; if there is a mismatch, there will be a warning in Rasoft Pro when 
connecting to the HUB.  
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A1.2.2 Configuration 
 
➔​ Right-click the HUB in the Communication Devices 

 
➔​ Select "Open in Browser" 

 
 
➔​ A web browser will open the HUB web pages.  

 
➔​ If this is the first time opening the HUB, the Setup Wizard will begin. Select "Next" 

 

 
 
➔​ Choose a password and select "Next". 

​  
 
➔​ Choose a name for the HUB, as well as the House address matching the Project in 

Rasoft Pro. Select "Next".  
​  
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➔​ Select "Finish"  

 

 
 

 
 
As a final check, it is advisable to disconnect and reconnect to the HUB: 
 

 
 

If no pop-up box appears, then the HUB House number and Project file House number are 
the same. 
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A1.2.3 Adding the HUB as a Device in Rasoft Pro 
 
Once the HUB has been configured in the web pages, it needs to be added as a Device to 
Rasoft Pro to upload the Room and Room information for App control.  
 
➔​ Connect to the HUB by double-clicking it in the Communication Devices; a green 

tick will show to verify the connection has been successful.  
 

 
 
➔​ Go to "File > New Device" 

 
 
➔​ Select "HUB/Bridge" and "Next" 

 

 
 
➔​ The IP address of the HUB will appear in the next window; highlight it and select 

"Finish"  
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➔​ The HUB has now been added as a Device in Rasoft Pro.  

 
Once the HUB has been added as a Device, it will require further setup for App control. See 
A4 Uploading to a HUB/Bridge and App setup for further information.  

Appendix 2 Power-Up Mode 
The Power-Up mode determines the Level or Scene a Device will output when it is initially 
switched on at the supply.  
 

 
 

A2.1 Setting A Global Power-Up Mode 
 
It is possible to set the Power-Up Modes “globally” for the entire System. To access this 
menu:  
 
➔​ Select “Tools” > “Global Power Up”. 

 
 
➔​ Select the Power-Up Mode required.  
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➔​ For systems which are left empty for long periods of time, "Off" is a recommended 

Power-Up Mode.  
 

➔​ Systems that are constantly in use, "Last Scene" is a recommended Power-Up Mode.   
 

Appendix 3 Fade rates 
Using Rasoft Pro, it is possible to edit the rate at which Rako modules Fade between 
Lighting Levels.  

A3.1 Change the Fade Rate for a Room  
 
➔​ Open the Room editor, right-click Room Devices and select "Fade Rates".  

 

 
 

 
 
The Fade Rate menu will be displayed as below. 
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Two types of Fade Rates can be adjusted: 
 
Scene controls  
 
The rate at which Circuits move between Rooms (including Off). 
 
Fader controls  
 
Will change the rate at which Circuits dim up or down when the Fade buttons (raise/lower) 
are used. 
 

 

A3.2 Change the Fade Rate for a Channel 
When a specific Room requires a change in Fade Rate, it can be adjusted in the Room 
Editor. 
 
➔​ Go to the Room Editor, and right click the assigned Device, select "Go to (Device)" 
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➔​ Select the "Fade Rate" tab 

 

Appendix 4 Uploading to a HUB and App setup 
After a system has had all Rooms, Channels and Devices added, the information needs to 
be uploaded to the HUB in order to control the System via the App and the web pages.  
 
➔​ Select the HUB in the Device List 

 

 
 
➔​ Select "Smartphone/Web Data" 

 

 
 
➔​ Select "Save & Upload Room Data to HUB/Bridge" 

 
The Room, Channel and Scene information is now uploaded to the HUB, and can be 
accessed via the Rako App or via the HUB webpages.  

A4.1 Room Mode 
 
The App will display a 4 Scenes + Off arrangement by default. There are additional options 
depending on the control panels used and the number of Scenes required in the App.  
 
To change the Room Mode: 
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➔​ In the Smartphone/Web Data section, select the "Mode" drop down menu for the 
relevant Room. 

 

  
 
➔​ Select the required option for each Room. 

 

 
 
➔​ Select "Save & Upload Room Data to HUB/Bridge" 

 

 
 

A4.2 Room Type 
 
If a Room is not for dimmable lighting, the Type can be changed. 
 
➔​ In the "Smartphone / Web Data" menu, select the "Type" drop-down menu for each 

Room to specify its Type.  
 

 
 
 
➔​ Once the Room Types have been set, select "Save & Upload Room Data to HUB. 
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A4.3 Channel Type 
 
Similar to Room Type, individual Channels can be set to different circuit types. The most 
common use is setting a non-dimmable circuit to "Switch", which will remove dimming 
options on the App and instead give an "On/Off" option.  
 
To set a Channel Type: 
 
➔​ In the Smartphone/Web Data section, select the Room to highlight it and select the 

"Type" drop-down menu for the relevant Channel. 
 

 
 
➔​ Once the Type has been selected for all of the relevant Channels, select "Save & 

Upload Room Data to HUB/Bridge" 
 

 
 

A4.4 Smartphone / Web Data Options 
 
Enable 
 
When the box is ticked, the Room will appear in the App. Rooms which are not intended for 
direct control via the App should be unticked.  
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Title 
  
The names of the Rooms on the left side menu will be displayed here, and the names in the 
list will appear in the App.  
 
Type 
 
Changes the options available for the Channel in the App, for example, if a circuit is 
changed to a "Switch", in the App an "On/Off" layout will be shown rather than a Slider.  
 
Mode 
 
Depending on the requirements of the Room on the App, the Mode can be set to show 
different button configurations, the correct configuration will depend on the individual 
requirements as well as the Keypads used.  
 
Room Order 
 
The order of the rooms can be adjusted by selecting the header to sort numerically or 
alphabetically, and by dragging the rooms up/down to create a customisable order.  
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